Ecobee App Authorization via beestat

Longtime user who recently enabled 2FA. I understand this breaks the ability to authorize the app so I disabled 2FA, but am still unable to authorize beestat. I changed my password, am able to login to the Ecobee app and via the web, but Ecobee authorization fails and says I have the wrong password when trying to authorize via beestat.

Anyone experienced this or have a fix?

The two issues I am aware of with authorization today (both ecobee issues) are:

  1. If 2FA is enabled, the authorization does not work. Fix: Disable 2FA.
  2. If you are logged into your ecobee account in the same browser you are authorizing beestat with, the authorization does not work. Fix: Log out of ecobee.com or try a different browser.

Does the second option fix your issue?

Is there a plan (or even the capacity) for beestat to work with 2FA enabled? You can’t view live video via the camera without 2FA.

It’s unfortunately not up to me; this is a bug with the ecobee authorization workflow. If you enable 2FA other integrations like google or IFTTT will exhibit the same behavior.

I know ecobee is working on this, so hopefully in the coming months we’ll see a resolution.