Help, I can't authorize beestat!

:star::star:
Edit: This should now be fixed!
:star::star:

I am going to attempt to direct and merge all discussion related to authorization problems into this thread. It’s been brought to my attention that numerous users have been unable to authorize beestat lately. This prevents them from logging in and using the application.

:point_down:t3::point_down:t3:
There are a number of known issues that can be resolved. For a list of those, see here. Please make sure you have tried those solutions first.
:point_up_2:t3: :point_up_2:t3:

Those aside, there are still users who are unable to authenticate. If it were just one person I might say it’s a bad password, but there are several users who have followed all the troubleshooting steps and still cannot log in. If you find a solution, please share it here.

I am currently exploring switching to a newer authorization workflow with ecobee to see if that helps. If you are interested in following the technical discussion, see here:

1 Like

On Reddit /u/proghostbuster noted:

I’ve been having the same issue and did not have 2FA enabled. Had to change password but verified that it is letters/numbers only.

I tested IFTTT and it worked and connected with no issues. I noticed that the auth url’s were different from beestat and IFTTT.

IFTTT: https://auth.ecobee.com/u/login?state= beestat: https://www.ecobee.com/home/oauth/login.jsp?p=

I’m guessing, but IFTTT is probably using the newer authorization workflow that I am trying to get access to.

Update: I am working with ecobee to enroll in their early access authorization workflow. I am currently getting a test project enrolled so I can make sure everything works and make any necessary changes.

1 Like

Thanks for working this!

I validated today that I experience the same as: Reddit /u/proghostbuster . Can authenticate via IFTTT, but not beestat.

To add more to this, the authorization issues occurred after I changed my password with Ecobee. I made sure that it was alphanumeric only and met the password requirements. After that, I was no longer able to connect beestat and when it directed me for authorization, the Ecobee site said that the username/password was incorrect but I was able to sign in on Ecobee’s site directly and setting up IFTTT also worked.

Out of desperation of missing beestat and it’s awesome dashboard, I tried changing my Ecobee password back today to what it was before, which was shorter and less complex but still alphanumeric. Then I tried to connect beestat back to Ecobee and it worked exactly as expected.

I still think integrating with Ecobee’s new JWT based auth workflow is the way to go but this tells me that maybe there is some bug with Ecobee’s previous auth that had issues with more complex passwords.

1 Like

I am now using the new JWT workflow on my development project. I would be interested in having some users try this over the weekend to make sure there are no issues. Please let me know if you are willing. All you are required to do is log in at a special development site and click around a couple times throughout the weekend. None of your live data will be affected.

I just learned about this site and am having the same issue. I can login to the main ecobee site, but when coming from beestat, the login screen says invalid pw. I did somehow manage to add the app to my account however. One time I saw the ‘authorize’ screen but once clicked, it just sent me straight to ecobee.com.

Hey! Hold tight. I wrapped up my testing and am working on getting the switch made to hopefully resolve this soon.

Having the same issue too. I changed my password with Ecobee. I made sure that it was alphanumeric only and met the password requirements and i disabled 2FA. I just wanted to let you know.

I have just switched to the new JWT authorization workflow. If you were having issues, please try again.

Yes it works! I was presented with a new authorization screen and clicked ‘yes or ok’ and never even needed my userid/pw. Then it sent me straight to the dashboards. I was also concurrently logged into the regular ecobee dashboard site, so there’s no need to logout there. Thanks for your hard work!

1 Like