Thermostat Detail Chart not updating but sensors are

Stopped updating yesterday yesterday at 8:25pm. Sensors still show data from then until now. If I go in my app it tells me the outside weather data so it should be getting that correctly.


For some reason ecobee stopped reporting local weather data last night. For technical and performance reasons, beestat throws away data where local weather is not present. It’s generally very reliable; I’ll try to find out what’s going on. Thanks for the report!

1 Like

It has also impacted your new visualization tab.

Also, my flair vents app has started behaving badly. Maybe ecobee changed something about their data that is impacting both beestat and flair?

I see the same problem but Ecobee does not throw away run time data when the weather data is not reported so all your run time data is available by logging onto ecobee and downloading yesterday’s data.

Just remember that, unlike Beestat that fully separates Stage one from Stage two ( if you have a two stage system ) , Ecobee’s Heat Stage 1 (sec) data is actually total run time

Heat Stage 1 (sec) / Heat Stage 2 (sec)

15 ______ 0
300______ 0
300_______ 15
195______ 195

Having same issue here in chicago.

Look forward to fix. Ironically just changed some settings last night (longer min heat run time), so wanted to check to see how that impacts things.

Thanks for your hard work.

My evaporator froze yesterday and I had just defrosted it and really needed to monitor things to make sure it was running properly. But things happen lol

Just joined to say the same thing is happening here, just outside Milwaukee.

It is amazing how dependent we become of this tool. I also made some changes last night and was looking forward to analyzing the impact.


I tried this and when I downloaded the data its all blank at the same cutoff as the graph around 8:25

It worked for me. I have run time data from Ecobee for four starts after the temp line goes blank ( RED)/ This shows one of them in yellow

PERHAPS the reason is I am running a two-stage Geothermal unit… IDK

“We’ve pinned down the issue and are acting quickly with a fix.”

Edit: My thermostat detail is populating again.


I am seeing data populate in beestat now

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.